Incorrect base item weapons constantly dropping in high lvl Sarisel runs

Hello, I would like to report something that simply has to be a bug - incorrect item bases dropping from the chest of a Sarisel run (I run lvl 163s)

So to clarify : whenever I run high level Sarisel expeditions, usually lvl 163, 151 or 115 - the final chest will NEVER drop the highest tier weapon bases - instead of t16 weapon bases it ALWAYS drops t11 bases. So a Fallen Ivory Axe will never drop - instead it always drops Manslayer Labrys. Same with Fiendish Heartsplitter - never drops, only Horizon's End drops instead. And instead of Profane Executor, a Ravenyx Halberd always drops instead.

There is nothing in between - tier 12 - 15 weapons bases NEVER drop - its only tier 11 weapon bases. I can understand you wanting to have loot variance and not have ONLY the highest tier weapon bases drop in a run - but clearly if I have never seen any weapon base from t12 - 15 it has to be some kind of bug? Loot variance would include bases dropping from all tiers right?

Some things to note :
1. This does not happen with armor - the highest tier armor bases such as Elemental Basinet and Festering Exoskeleton still drop normally from the Sarisel chest.
2. During the actual run (so before opening the final chest) - if I find a cursed chest or open a chest or other container - the highest tier weapon bases CAN drop normally, just not from the final chest. T16 weapon bases can also still drop from monsters. But I noticed that an abundance of t11 bases STILL drop from cursed chests, containers etc during the run.
3. If I DON'T choose Sarisel and instead run the expedition normally, the bug does not occur of course - since as stated above - the bug only seems to affect the final chest in a Sarisel run, and only affects T16 weapon bases - dropping a t11 base whenever a t16 base SHOULD drop.
4. The funny thing about this is the t11 bases are still dropping with highest possible rolls and affixes.
5. Negative impact of this bug includes not being able to target high level weapons through Sarisel runs, and also this is creating ridiculously powerful t11 weapon bases that only require character lvl 41 to use - clearly unintended. It really sucks to get all that loot from the final chest, see the most perfect rolls I've been hoping for on a 2handed sword - only to discover its a Horizon's End base and not a Fiendish Heartsplitter :(

I did not notice this bug among your list of current known issues so I thought I would make this post. Thanks for a great game and all your hard work.

Replies: 2

Created: 2 years, 10 months ago

Category: Bugs & Issues

I noticed this as well at level 187 runs.

Created: 2 years, 10 months ago

yes, thats quite annoying, please fix this :) on level 187 runs for me as well...

Created: 2 years, 9 months ago

Your email is not verified, resend your confirmation email from your profile page.