Performance Problem

Hello,

I'm getting ~90 fps in Stormfall after a fresh restart of the game, which then only gets worse after playing for an hour or so. I'm playing the Arctic Spear/Havoc Orb build(Lots of explosions and effects on screen). So even after some farm runs, my fps drops down to about 30-40. Meanwhile my CPU and GPU are chilling at 40-60%. Something is holding me back from getting sweet 144 fps :)

My Pc specs:

intel i7 4790k @ OC 4,7 GHz
16GB DDR3 @ 1866 MHz
Geforce RTX 3070 OC (461.09 Driver)
Windows 10 20H2
game is installed on a nvme Samsung 960 EVO

Here is a picture of CPU/GPU usage, fps counter, and ingame settings:

https://ibb.co/JQzxdgL


Thank you Wolcen guys for constantly patching/fixing the game. If you need more infos, just let me know. Cheers and stay healthy <3

Replies: 9

Created: 1 year, 10 months ago

Category: Bugs & Issues

You're not the only one, the performance dropped is huge :((( im running same setup as yours with i5 [email protected] and also experience frps dropped 29-50 lol
Before Bloodtrail didn't have such problems

(Edited 1 year, 10 months ago)

Created: 1 year, 10 months ago

Same here.

Created: 1 year, 10 months ago

I wonder what the problem is. I mean something is supposed to bottleneck before running into to a (fps)wall. Like one or more CPU cores constantly at 100%, or GPU at 100% usage, but it's not the case here. Weird stuff happening here. Devs might be working on it already.

I agree, before Bloodtrail, I had some more fps despite using my old Geforce 1070 OC.

Created: 1 year, 10 months ago

I have a 6900XT and a 5800x overclocked to 4.85Ghz and I'm getting 80-90FPS in town, 60-100FPS in dungeons. Is this normal?

Created: 1 year, 10 months ago

No. It's like that since Bloodtrail. Everything ran a little smoother before. Considering your NASA computer, you should get 250+ fps.

Created: 1 year, 10 months ago

No. It's like that since Bloodtrail. Everything ran a little smoother before. Considering your NASA computer, you should get 250+ fps.

anuran Original Comment

That's what I thought, I played before Bloodtrail or whatever it's called and I don't think my monitor showed me under 240hz. Right now it's unplayable.

(Edited 1 year, 10 months ago)

Created: 1 year, 10 months ago

hey Guys,

i Got a nearly Problem:
my Setup:
i7-7700K
gtx 1080 ti
32gb ddr 2400

after reaching expedition lvl 110+ my fps starts going down to 40 (70fps stable before legendarys etc)

if a fried joins my Fps falls to 15-25

we found a quiet interresting point
When u dont wear a Armour the Fps goes per visible item 5 to 10 higher.(bodyarmour most effective)

so if im naked i got 120fps.. with full armour 40.. 2. player wirh armour 15-25

does Anyone got a solve for this problem or can see the same effect?

(Edited 1 year, 9 months ago)

Created: 1 year, 9 months ago

The problem occured with the Bloodtrail update, which means that we, as players, can't do anything. Developers botched optimization with the patch, and it's February already. They won't fix it, just as they haven't fixed the EU server lag.

Created: 1 year, 9 months ago

Hey Guys
i have exactly the same problem, on release of this game i hat 144 fps max because my Motinor is limit it :)
but now...ahm 20 ~30 fps?
my speccs

-RTX2080Super
-Intel i9-9900
-32BG RAM
this game runs on Evo980 M2 and all my game works fine, but the same issues i have it on the same Game "Kingdomcome-Deliverence" maybe the same bottleneck ?

Created: 1 year, 6 months ago

Your email is not verified, resend your confirmation email from your profile page.