Refine threads

Pick a category

Pick a subcategory
Bug Reports

Report bugs encountered in game.

Technical & Connection Issues

Report launch issues, crashes, technical and connection issues.

Website and Forum Issues

Spotted a bug on the website? You can report it in this section!

Localization

Report issues related to the localization or missing strings

Support

If you need assistance from our Customer Support team, this is the place to be!

Bugs & Issues

Create a thread
All Threads in Bugs & Issues Replies Activity
Bonus production missions are bugged still
By Forshowws · · in Bug Reports
Replies 0 Activity
Start mission button no longer visible on screen (3840x1600)
By Mortimer Blackwood · · in Bug Reports
Replies 0 Activity
Game creation failed
By torquadon · · in Technical & Connection Issues
Replies 1 Activity
Bloodtrail is gone after joining the next area in expeditions.
By leo.hoek · · in Bug Reports
Replies 0 Activity
Lost equipped Items on relogging
By Dr.Abriss · · in Bug Reports
Replies 0 Activity
Bonus production missions are bugged?
By Forshowws · · in Bug Reports
Replies 0 Activity
Offline mode
By cedric.cato · · in Bug Reports
Replies 0 Activity
Bugged Pants
By pilcrow81 · · in Bug Reports
Replies 0 Activity
Game Creation Failed
By thebereaver · · in Technical & Connection Issues
Replies 1 Activity
Broken inventory
By Forshowws · · in Bug Reports
Replies 1 Activity
Server is laggy
By Forshowws · · in Technical & Connection Issues
Replies 0 Activity
Evasion with Sanguine Blast is bugged
By Forshowws · · in Bug Reports
Replies 0 Activity
Losing Progress
By Supa · · in Bug Reports
Replies 0 Activity
Keep getting kicked out of the game.
By MorningOwl68 · · in Technical & Connection Issues
Replies 0 Activity
Black market
By Glot · · in Technical & Connection Issues
Replies 0 Activity
null_umbra_items still in game on year later......
By Forshowws · · in Bug Reports
Replies 1 Activity